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Universal Type Server Core Client 
What is the Universal Type Core Client? 
The Core Client is a scaled-down version of the full Universal Type Client designed for organizations that need to 
manage fonts across their company but don’t require all of the functionality in the full client. 

Editorial and non-creative users often require only a small set of the fonts for their everyday tasks. A full-featured 
client application is usually much more than these users need. The Universal Type Core Client doesn’t have the 
user interface of the full client but still delivers strong protection from rogue font usage. It governs which licensed 
fonts can be activated, prevents illegal system font usage and reports font usage back to Universal Type Server 
for licenses being consumed. 

Core Client Key Advantages: 

• Compliance: Keeps every computer in your organization licensed and legal! 
• Consistency: Organize and distribute fonts to all users across the organization to ensure consistency. 
• Prevention: Close the holes and prevent users from introducing rogue fonts onto their systems and into 

the workflow. 

NOTE: The Core Client is only available as an add-on with the Enterprise edition. 

When the Core Client starts, it automatically activates all fonts that are in Startup Sets. A Startup Set consists of 
fonts that a Universal Type Server administrator has determined that all users must have active at all times. 

The Core Client will also enforce whatever system font policy is specified for the user. The administrator can 
designate which fonts are allowed in the user’s system fonts, and if the user attempts to install other fonts they 
will be automatically removed. 

Preparing for the Core Client 
To prepare your Universal Type Server and user systems for the Core Client, you will need to do the following: 

1. License the Core Client. 
2. Download the Core Client installers. 
3. Confirm that user systems meet the Core Client system requirements. 
4. Create Core Client user accounts in the User and Workgroups Management application. 
5. Create Startup Sets. 
6. Install the Core Client. 
7. Create a configuration file. 
8. Deploy the configuration file. 

In order to license the Core Client, you will need to use the Universal Type Server Administration application. 

In order to create user accounts, you will need to use the Users and Workgroups Management application. 
These applications are accessed from your Flash-enabled web browser. 

In order to create Startup Sets, you will need to use the Universal Type Client application. 

IMPORTANT 
The Universal Type Client and the Core Client perform many of the same functions behind the scenes and are 
not compatible. Do not install the Universal Type Client on a system where you will be installing the Core Client. 
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Licensing the Core Client 
The Core Client can be licensed for use with the Enterprise Edition of Universal Type Server. To enter a serial 
number for the Core Client: 

1. Start your web browser and log in to the Server Administration application. 
2. Click the Licenses link on the left. 
3. Type or paste your Core Client serial number into the field labeled Add Serial Number, then click the 

 Add Serial Number  button. 
4. Confirm that your license was added correctly, then click Logout. 

If you would like to install the Core Client on a trial basis, please contact Extensis Corporate Sales for a trial 
serial number. See Contacting Extensis on page 9. 

Downloading the installers 
You can download the Core Client installer from the Universal Type Server updates page on the Extensis 
website at http://www.extensis.com/en/support/universal-type-server.jsp. Be sure to download installers for the 
platforms you are supporting: Macintosh, Windows, or both. 

System requirements 
The Core Client has the same system requirements as the Universal Type Client. The most up-to-date 
requirements can be found online at http://www.extensis.com/en/font-management/universal-type-server-
3/system-requirements.jsp. 

User accounts 
All Core Client users need to have an account on your Universal Type Server. You can use an LDAP server to 
authenticate existing network users, or you can create user accounts manually. 

For details about adding network user accounts to your Type Server, see the Directory Integration section of 
the Universal Type Server User Management help system or User Guide. 

For network user accounts, you may still wish to change some of the account settings as described below. 

NOTE 
The Core Client can be used with Directory Integration and Kerberos single-sign on to automatically connect the 
user to the correct Type Server without having to enter a password. 

To create a user account: 
1. Start your web browser and log in to the User Management application. 
2. Click All Users or choose a specific workgroup in the Workgroups list on the left. 

If you choose a specific workgroup, the user account will be added to that workgroup automatically. 
3. Click the [ + ] Add button at the bottom of the Users list to add a new user. 
4. In the user account pane on the right, enter the appropriate information in the Account panel. 
5. In the Settings panel, only a few options are used for Core Client users: 

Change Password: Check this box to allow the Core Client user to change his password. 
Time between server syncs: The Core Client will “check in” with the Type Server at this interval and 
activate or deactivate fonts as needed. 
While the default value is 5 minutes, most Core Client users will not have frequent changes to their 
available fonts, so you can safely change this to a larger interval, or even Manual. (The Core Client will 
always synchronize with the Type Server when it establishes a connection, and the user can launch the 
Core Client and perform a manual sync at any time.) 
Enforce System Font Policy: Check this box to have the Core Client monitor the user’s system fonts and 
disallow removing required fonts or adding new fonts. 
Disable Startup Sets: Fonts in a user’s Startup Sets are automatically enabled when the Core Client 
connects to the Type Server. If you check this box, fonts in Startup Sets will not be enabled for the user. 
You might choose to disable Startup Sets but enforce a system font policy for users that do not need to 
use fonts other than those required by their operating system. 
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6. Click the  Save  button to save the user account. 
7. Add the user to a workgroup by dragging his name from the Users list to the desired workgroup in the 

Workgroups list. 

For details about user accounts and account settings, see the Users section of the Universal Type Server User 
Management help system or User Guide. 

Creating Startup Sets 
The Core Client uses Startup Sets to determine what fonts to activate for Core Client users. In order to create 
Startup Sets, you must connect to your Type Server with Universal Type Client using an account that is either a 
Font Administrator or a Workgroup Administrator in the same workgroup as the Core Client user. 

To create a Startup Set: 
1. In Universal Type Client, select the workgroup you want to add the Startup Set to. 
2. Select fonts in the font list that you want to include in the Startup Set. 

You can add more fonts or remove fonts at any time. 
3. Choose File > New Set from Selection. Enter an appropriate name for the set. 
4. With the new set selected, choose File > Share Set, then choose File > Startup Set. 
5. If desired, add more fonts to the Startup Set. 
6. When finished adding fonts, quit the Type Client. 

For more information about sets, see the Sets section of the Type Client help system or User Guide. 

The configuration file 
Rather than requiring the user to enter server information, the Core Client relies on a configuration file to supply 
the server connection information. This file must be present in order for the Core Client to connect to the server. 

If your users will all connect to one Type Server, you can create one configuration file and deploy it to all users. 

In order to create the configuration file, you will need a text editor capable of saving a plain text file in UTF-8 
format without a byte order mark (BOM). You can use TextEdit on Mac OS X and Notepad or WordPad on 
Windows. 

If you prefer a more robust editor, we recommend TextWrangler from Bare Bones Software for Macintosh (visit 
http://www.barebones.com/products/textwrangler/), and Notepad++ for Windows (available at http://notepad-
plus-plus.org). 

The configuration file consists of at least one or two lines that identify the server to the Core Client. You can 
specify the server by address and port, or using its Bonjour name. (See the Server Status section in the Server 
Administration help system or user guide for information on setting the server’s Bonjour name.) 

Example: IP address and port 
server.address=12.34.56.78 
server.port=8080 

Example: DNS name and port 
server.address=example.com 
server.port=8080 

Example: Bonjour name 
server.bonjour=Universal Type Server 

NOTES 

• If you include the server.address parameter, you must include the server.port parameter. 
• If you include the server.port parameter, you must also include the server.address parameter. 
• If you include both server.address and server.bonjour, the Bonjour name will be used to make the 

connection. 
• The default port for Core Client communication is 8080. 
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Saving in UTF-8 format 

The configuration file needs to be named com.extensis.TypeServerCoreClient.conf. You can either 
save your file with this name or rename it when you have finished. If your text editor appends a .txt or other 
extension, be sure to remove it before deploying the file. (In Windows, you may need to disable Hide extensions 
for known file types in the View panel of the Folder Options control panel.) 

• In TextEdit on OS X, choose Format > Make Plain Text to convert your file to plain text, choose File > 
Save, then choose Unicode (UTF-8) from the Plain Text Encoding pop-up menu. 

• In Notepad on Windows, choose File > Save, then choose ANSI from the Encoding pop-up menu. (Do 
not use Notepad’s UTF-8 format; this adds a byte order marker which is not recognized by the Core 
Client.) 

• In WordPad on Windows, choose File > Save, then choose Text Document - MS-DOS Format (*.txt) 
from the Save as type pop-up menu. 

• In TextWrangler on OS X, choose File > Save, then choose Unicode (UTF-8) from the Encoding pop-up 
menu. 

• In Notepad++ on Windows, choose Encoding > Encode in UTF-8 without BOM before saving the 
configuration file. 

Installing the Core Client 
The Core Client installer is fairly straightforward. Copy the installer to the client computer, or use a copy on a CD 
or thumb drive. 

TIP: If you copy the installer to a thumb drive, you can also copy the configuration file to the drive and deploy it 
immediately after installation is complete. 

Double-click the installer application icon and follow the instructions in the installer screens. You should accept 
all the installation defaults. 

If you have copied the installer to the client computer, be sure to remove it when you have completed the 
installation. 

Deploying the configuration file 
Once you have created the configuration file, you need to copy it to the computers where you have installed the 
Core Client. 

• On Macintosh, copy the file to the /Library/Preferences/ folder. 
• On 64-bit Windows, copy the file to C:\Program Files (x86)\Extensis\Type Server Core 

Client\. 
• On 32-bit Windows, copy the file to C:\Program Files\Extensis\Type Server Core Client\. 

Using the Core Client 
Most of the time the Core Client will function in the background. The only times a user needs to interact with it is 
to log in, to perform a manual synchronization, or to uninstall it. 

Logging in 
The Core Client installer sets the Core Client to start automatically when a user logs in to the computer. If the 
configuration file has been created properly, the user will be presented with a connection window, where they 
need to enter their Type Server account username and password. 

If Directory Integration with Kerberos Authentication is configured on your Type Server, the user will be 
automatically logged in to the Type Server and will not see the connection window. See the section on Directory 
Integration in the User Management help system or User Guide. 

If you need to start the Core Client manually: 

• On Macintosh, double-click the Type Server Core Client icon located in the Applications folder. 
• On Windows, choose Type Server Core Client from the Start menu. 
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Manual synchronization 
Core Client users are automatically synchronized with your Type Server based on the Time between server 
syncs specified for their account. Synchronization retrieves fonts in the user’s Startup Sets and applies the 
System Font Policy. 

Users can also manually synchronize fonts at any time. 

To manually synchronize fonts:  
1. Start the Core Client. 
2. Click the  Sync  button. 

To force the Core Client to re-download all fonts and settings instead of just new fonts and changes, hold down 
the OPTION key (Macintosh) or SHIFT key (Windows), then click  Sync . 

Uninstalling the Core Client 
Macintosh 

1. Quit the Core Client if it is running. 
2. Open the Accounts system preferences panel. 
3. Click the lock icon and enter your password to authenticate. 
4. Click the Login Items tab. 
5. Select the Type Server Core Client in the list of items and click the [ — ] button. 
6. Quit System Preferences. 
7. Delete the file Type Server Core Client in the Applications folder. 
8. Delete the Core Client folder located in \Library\Application Support\Extensis\. 

Enter your password when you are prompted to authenticate. 
9. Restart your computer, then empty the Trash. 

Windows 
1. Quit the Core Client if it is running. 
2. Open the Programs and Features control panel (Windows 7/Vista) or Add or Remove Programs 

(Windows XP). 
3. Choose Extensis Universal Type Core Client. 
4. Click Uninstall (Windows 7/Vista) or Remove (Windows XP). 
5. Follow the prompts to uninstall. 
6. Restart your computer. 
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Contacting Extensis 
Extensis 
1800 SW First Avenue, Suite 500 
Portland, OR 97201 
Toll Free: (800) 796-9798 
Phone: (503) 274-2020 
Fax: (503) 274-0530 
Web: http://www.extensis.com 

  Extensis Europe 
Suite 18, Newton House 
Kings Park Road, Moulton Park 
Northampton NN3 6LG, United Kingdom 
Phone: +44 (0)1604 654 270 
Fax: +44 (0)1604 654 268 
Email: info@extensis.co.uk 

Customer Service 
Web: http://www.extensis.com/customerservice/ 
Phone: (800) 796-9798 

  Celartem, Inc. 
Phone: +81 3 5574 7236 
Email: sales_ap@celartem.com 
Web: http://en.celartem.com 

Documentation Feedback 
Web: http://www.extensis.com/helpfeedback/ 

Corporate Sales 
Web: http://www.extensis.com/corporatesales/ 
Phone: (800) 796-9798, ask for Corporate Sales 

Technical Support 
Technical Support is available directly through the Extensis website or by telephone. 

Web: Fill out the form at http://www.extensis.com/support/. 

A support representative will respond by phone or email, usually within 24 hours on weekdays. 

Phone: Please call (503) 274-7030 in North America, or +44 (0) 1604 654 270 in Europe. 

When contacting technical support, please include the following information: 

• Your product name and serial number(s); 
• Your computer configuration, including operating system, memory, and hard drive configuration; 
• Your question, or a description of the difficulty you’re experiencing: what specifically occurs and when; 
• Your phone number if you want to have a representative call you. 

Take note of any error numbers or messages that display and any other information you think may be relevant. 

For answers to frequently asked questions and troubleshooting tips, you can also visit the Extensis website at 
http://www.extensis.com/. 

Priority Support 

If you have an Annual Service Agreement, you are entitled to priority support. Please call the telephone number 
listed on your agreement to receive support 24 hours a day. 
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