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Portfolio Server is a powerful database server, 
allowing access to Portfolio catalogs using the 
standard Portfolio client application software. 
Unlike typical server applications however, the 
Portfolio Server is easy to set up and use, and 
requires almost no maintenance.

Portfolio SQL Connect (sold separately) allows 
Portfolio Server and the client application to create 
Portfolio catalogs on an SQL database server, 
such as Microsoft SQL Server or Oracle. These 
SQL hosted catalogs appear to the Portfolio client 
application as standard Portfolio catalogs, while also 
allowing advanced integration opportunities and 
administrative management of the SQL database.

Portfolio NetPublish Server (sold separately) allows 
you to create static or dynamic web sites of your 
Portfolio catalogs. You don�t need to be an expert 
to create your site - the NetPublish Assistant walks 
you through all steps of the process. Advanced users 
can also create custom sites through access to the 
powerful server-side JavaScript API. 

Technical Support

Technical Support is available directly through the 
Extensis web site. Please �ll out the online support 
form at http://www.extensis.com/support/ to get support.  
Our tech support representatives will respond by 
phone or e-mail, usually within 24 hours on 
weekdays. 

When contacting technical support, include the 
following information: 

� Your Portfolio serial number

� Your computer con�guration

� Your question or a description of the dif�culty you�re 
experiencing - what speci�cally occurs and when 

�	Your phone number if you wish to have our 
representatives call you 

Take note of any displayed error numbers or 
messages and any other information you think may 
be relevant.

For answers to frequently asked questions and 
troubleshooting tips, you can also visit the Portfolio 
page on the Extensis web site:

http://www.extensis.com/portfolio/ 

Introducing Portfolio Server

http://www.extensis.com/support/
http://www.extensis.com/portfolio/
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About this User Guide

This Quick Start Guide covers Portfolio Server 
for Macintosh and Windows. When describing 
keyboard shortcuts, �Command� refers to the Ѓ key 
on the Macintosh. References to menu selections are 
shown as Menu > Command. 

For more information on speci�c Portfolio features, 
refer to the following:

�	Read Me-located in your Portfolio folder, this text �le 
gives you late-breaking information 

�	Portfolio page on the Extensis web site:  
http://www.extensis.com/portfolio/

http://www.extensis.com/portfolio/
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Portfolio Server is a powerful catalog server, 
allowing access to Portfolio catalogs using the 
standard Portfolio client application software. 
Unlike typical server applications however, Portfolio 
Server is easy to set up and use, and requires almost 
no maintenance.

This chapter covers the setup, con�guration and 
administration of Portfolio Server.

There are many bene�ts of using Portfolio Server, 
including the following:

�	Portfolio Server facilitates multiple simultaneous 
client connections to a single catalog.

�	Server and catalog administration is performed 
from the standard Portfolio client application. 
Administration can happen from any client, remotely 
over TCP/IP, regardless of the client platform.

�	A high level of network security is available 
because served Portfolio catalogs are 
not available on network shares.

�	All catalogs are stored in a single location, making 
backup and database �le management simpler and 
helping stabilize the integrity of shared catalogs.

�	Network administrators can provide a uniform 
method of access to Portfolio catalogs regardless 
of the client platform. Macintosh or Windows 
users do not need to run any other �le sharing 
applications to access served catalogs.

Server vs. Catalog Administration

When using the Portfolio client application in 
conjunction with the Portfolio Server, two different 
types of Administration are available:

Server Administration: The Server Administrator 
has permission to administer the Portfolio Server. 
In addition, the Server Administrator creates, opens, 
and closes Catalogs on the Server. Client access 
is added through adding special multi-user serial 
numbers to the Server. Server Administrator duties 
are described in this section.

Catalog Administration: The Catalog 
Administrator has permission to access 
Administrator level functions for particular 
Catalog(s). Refer to the Portfolio User Guide 
for assistance with creating, managing, and 
administering catalogs.

Portfolio Server
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System Requirements 

Macintosh:
�	Mac OS X (10.4.4 or higher)

�	1GHz or faster G4, G5 or Intel Core processor(s)

�	512MB RAM

�	200MB of free hard disk space

�	QuickTime 7 or higher 

�	Network interface for client connection

�	Appropriate stoage, backup, power management and 
network bandwidth 

Windows:
�	Windows 2000 Server, Server 2003 or higher

�	Server class processor at 1GHz or faster

�	512MB of RAM (1GB recommended)

�	100MB of free hard disk space

�	Network interface for client connection

�	QuickTime 6.5 or higher 

Portfolio Server software normally bene�ts greatly 
from a faster processor, more physical memory, 
multiple processors, faster network connections, and 
faster hard drives.

Extensis does not provide Technical Support 
for con�guring TCP/IP Services, setting up 
DNS services, con�guring a �rewall, or other 
networking issues. For assistance with these 
issues, please consult your System Administrator 
or the product vendor�s technical support.

The Installation and Setup Process

The installation and setup of Portfolio is fairly 
simple and contains the following steps:

1.	Install Portfolio Server

2.	Launch Portfolio Server / Start the Windows Service

3.	Add the Portfolio Server

4.	Serialize Portfolio Server

5.	Create a catalog on the Server

6.	Connect users to served catalogs

Detailed instructions for each of these steps are 
included on the following pages. 

Installing the Server

Installing Portfolio Server is quick and easy. Simply 
launch the installer and allow it to guide you.

On Windows, you must be logged in with 
Administrative privileges to effectively install 
Portfolio Server. 

On Windows 2000 and Server 2003, the account 
that is running the Portfolio Server service must 
be logged in with Power User or Administrative 
privileges on the local machine. This is required 
so that Portfolio clients can access and 
administer Portfolio Server.

The Portfolio Server application has no interface 
itself; access to Server features is handled through 
the standard Portfolio client application software. 
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Launch the Mac Server or  
Start the Windows Service

Windows installation and starting the service 
Under Windows, the Portfolio Server is a system 
service. This service must be started on the Server 
before it is active. To do so, choose Start > Control 
Panel > Administrative Tools > Services. Select 
Portfolio Server from the list and click Start.

For use on a domain, the service must log on as an 
account that has access to all necessary asset folders. 
Assets can be anything that users are likely to add to 
Portfolio catalogs. This can be done by creating a new 
account for the service or using an existing account 
with the necessary privileges.

When installing Portfolio Server in a Microsoft 
Windows Workgroup environment, the Portfolio 
Server service should be logged into a non-
administration level account on the server. To do 
so, view the properties of the service, choose the 
Log On tab, check This Account and enter the 
account information. Any other machine on the 
workgroup must have the same server account 
created, yet does not need to be logged in. 

Macintosh installation and launching 
On a Mac, the Portfolio Server Launcher is used to 
start the server. Double-click to open the Launcher 
and click Start to start the server. 

Portfolio Server is automatically added to the 
Startup/Login items for the current user. Each time 
the current user logs in, Portfolio Server automatically 
starts. The Launcher can also be used to stop and 
disable Portfolio Server. The Disable button stops the 
server and removes Portfolio Server from the list of 
Startup/Login items for the current user.

Adding a Portfolio Server

Before you can serve catalogs on your Portfolio Server 
you must make the server available�that is, tell the 
Portfolio application where to �nd the server. You do 
this through the Server Administration dialog box.

To add a Portfolio Server:

1.	Launch the Portfolio client application.

	 You do not need to have a catalog open.

2.	Choose File > Administer Servers.

	 The Administer Servers dialog box is displayed. If no 
servers have been added, the servers list is blank.

3.	Click Add Server.

4.	Enter the name and IP address for the Server. 

It is highly recommended that your Portfolio 
Server use a static IP address. A DNS name can 
also be used in the IP address text box, but it is 
not recommended. 

See your operating system documentation for 
more information about locating the IP address 
or DNS name of your server.

5.	Click OK

	 The Server is added to the list and is available for users 
to access. 
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Serializing the Server

Portfolio Server is activated with a single Portfolio 
Server serial code. When you �rst install Portfolio 
Server, it runs in Demo mode for 30 days. After the 
trial period, you must enter a valid serial number to 
continue using Portfolio Server.

To serialize Portfolio Server:

1.	Choose File > Administer Servers > [select server] > 
Administer.

Before you Serialize Portfolio Server, you must 
�rst add the server to the list. See the previous 
page of this guide for complete details. 

2.	In the Administration dialog box, click Serialize. 

	 The Serial Codes dialog box is displayed. 

3.	Click Add. 

	 The Add Serial Code 
dialog box is displayed.

4.	Enter the Portfolio 
Server Serial Code then 
click OK.

	 When you click OK, 
you are returned to the 
Serial Codes dialog box. 
The newly entered code 
is listed.

5.	Click Done to return to the Server Administration 
dialog box.

Creating Catalogs on a Server

From the Administration dialog box for the selected 
server you can create new (empty) catalogs to be 
served on a Portfolio Server.

To add a catalog to a Portfolio Server:

1.	 Choose File > Administer Servers > [select server] 
> Administer.

2.	In the Server Administration dialog box, click New.

	 The New Catalog dialog box is displayed.

3. Enter the name of the catalog that you wish to create.

4.	Click OK.

	 The Catalog is added to the list of Catalogs in the 
Catalogs folder on the Server machine.

� or �

1.	Create a catalog from the Portfolio client.

2.	Copy the catalog (via the operating system) to the 
Catalogs folder on the server.

	 The default location on Windows is C:\Program Files\
Extensis\Portfolio Server 8\Catalogs\

	 On a Mac /Applications/Portfolio 8 Server/Catalogs/

	 You can now serve the catalog and make it available 
to your users. 
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Connecting Users  
to Served Catalogs

Once a catalog is served you will want to give users 
access to the catalog. The process from a Server 
Administration standpoint is summarized here.

To access served catalogs: 

1.	Note the name and IP address of the Portfolio Server. 

2.	Give the server name and IP address to your users.

3.	On the user�s machine, launch Portfolio and choose 
File > Connect to Servers.  

4.	Choose Add Server and enter the name and IP 
address of the Portfolio Server.

5.	Click OK.

6.	In the Connect to Servers dialog box, click the plus 
�+� icon to display a list of served catalogs.  

7.	Click to highlight a served catalog and 
click Open Catalog. The served catalog 
is opened in the Portfolio client. 

Notes on Accessing Served Catalogs:
�	When accessing a served catalog in Administrator 

mode, all other users must be logged off �rst. With the 
catalog closed, you can manually log users off from the 
Server Administration dialog box, or you can open the 
catalog as a Publisher then change your access level 
to Administrator to log off other users. Users can also 
simply disconnect from the catalog. Served catalogs that 
are already open in Administrator mode are not listed in 
the client�s Connect to Servers dialog box.

�	The client application attempts to open the catalog in 
the mode set in the user�s Preferences. If the preference is 
set to Administrator, the client application automatically 
attempts to connect to the catalog in Publisher mode.

The user is asked to enter a Password if the 
catalog requires it.

� For more information on installing and using the client, 
refer to the Portfolio User Guide.
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Administering a Portfolio Server

Portfolio servers are accessed and administered from 
the Portfolio client. To administer a Portfolio server 
choose File > Administer Servers. 

Once a Portfolio server has been made available to 
the network, the Server Administrator can: 

�	Create Catalogs to be served

�	Serve and Unserve catalogs

�	Open and close Portfolio SQL Connect 
(sold separately) catalogs

�	Log off individual users

�	Set/change Server Administration passwords

Refer to the Portfolio User Guide for further 
information about catalogs.

Serving and Unserving Catalogs
To serve (open for use) a Catalog on a  
Portfolio Server:

1.	Choose File > Administer Servers > [select server] > 
Administer.

2.	In the Server Administration dialog box, click Serve.  
A list of available Catalogs on the Portfolio Server  
is displayed.

	 � or � 

	 Navigate through folders and volumes accessible 
to the Portfolio Server to locate the Catalog to be 
served. Catalogs do not have to be located in the 

Catalogs folder to be served, but must include an 
Alias (Mac) or Shortcut (Win) to the catalog �le or 
folder directory from the Catalogs folder of the server. 

	 To create an alias on a Mac, in the Finder Ctrl-click the 
catalog and choose Make Alias. To create a shortcut 
in Windows, in the Windows Explorer, right-click the 
catalog and choose Create Shortcut. Move the new 
alias or shortcut to the Catalogs folder. 

3.	Select the Catalog that you want to serve,  
then click Serve.

To unserve a Catalog on a Portfolio Server:

1.	Choose File > Administer Servers > [select server] > 
Administer.

2.	From the list of served Catalogs, select the Catalog 
that you wish to unserve (make unavailable).

3.	Click Unserve

If users are connected to the Catalog, a warning 
dialog box is displayed. You can enter a delay time 
in minutes before the Catalog closes.

Connected users are noti�ed of the imminent 
closing so that they can close any open windows 
and connections related to that Catalog.
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Logging Off Users
1.	Choose File > Administer Servers > [select server] > 

Administer.

2.	From the list of served Catalogs, locate the 
Catalog with users that you wish to log 
off, then click the expansion arrow to view 
a list of active users on the Catalog.

3	 Select the user that you want to log off.

4	 Click Log Off User and that user is logged  
off immediately.

	 To allow users a time frame within which they can log 
themselves off (by closing their copy of the catalog), 
use the Unserve command.

Server Administrator Password
To set or change the Portfolio Server  
Administrator password:

1.	Choose File > Administer Servers > [select server] > 
Administer.

2.	Click Set Password

	 The Set Password dialog box is displayed.

3.	Enter and con�rm the new Server Administrator 
password, and click OK.

	 To exit the dialog box without affecting the 
password, click Cancel.

Removing a Portfolio Server  
Serial Code

This feature is helpful if you wish to move a serial 
number from one server to another, such as when 
setting up a Portfolio Server in a different location. 

To remove the serial number from a Portfolio Server:

1.	Choose File > Administer Servers > [select server] > 
Administer.

2.	Click Serialize. The Serial Codes dialog box  
is displayed.

3.	Click to highlight the Serial Code that you wish to 
remove, then click Delete.

The serial code is removed from the list, and  
those connections are no longer available on the 
selected server.

Notes on Served Catalogs
Portfolio Server and source images 

Portfolio Server does not serve the original �les, 
only the records of cataloged items. What this 
means is that the client machine must have access 
via the �le system to the original �le in order to 
perform functions that require the source �le, such 
as copy, move, rename, etc.

Server Port numbers

The Portfolio Server operates via ports 2903 and 
2904. Catalog assets travel over port 445  
for SMB mounted shares, and port 548 for AFP 
mounted shares. 

In order to avoid con�icts with other applications, 
make sure no other server software is using 
the listed ports on the server machine. (We are 
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currently unaware of any other applications that 
uses these port addresses.) Be aware that if you have 
clients attempting to access the server through 
a corporate �rewall, you may need to have the 
network administrator open holes in the �rewall for 
these ports.

The main server port number can be changed.  
See the Con�guration File chapter of this guide  
for detailed instructions.

Macintosh mounted shares

When running Portfolio Server on a Macintosh, 
all network shares that will potentially 
contain AutoSync folders created by users 
must also be mounted on the server. 

Also, when adding an AutoSync folder from 
a Windows Portfolio client to a catalog 
served by a Macintosh Portfolio Server, the 
user must navigate to the same share that 
the Macintosh server has mounted. 

For help in con�guring shared folders on a  
non-server version of Mac OS X, you may wish to 
consider a product named SharePoints. 
http://www.hornware.com/sharepoints/  
SharePoints makes it easy to add and delete 
share points like in the old Mac OS Finder. In 
Mac OS X, by default, you are limited to sharing 
only what is in your public folder in your home 
directory. This program makes it easy to share 
any folder.

AutoSync folders
AutoSync folders are basically FolderSync folders 
that can be automatically synchronized by the 
server. The bene�t of an AutoSync folder is that all 
of the work is done by the server. This way, you can 
do other work in your catalog while Portfolio Server 
automatically updates the AutoSync folders.

A new AutoSync folder must be on a share that is 
accessible by Portfolio Server. Only folders that are 
contained on mounted shares (Mac) or browsable 
through the network (Win) can be added. 

To add an AutoSync folder:

1. In the Folder View pane/drawer, click the Add Watch 
Folder button  

If you do not see the Folder View pane (Win) or 
drawer (Mac), choose View > Folders. 

2. Navigate to the folder you want watch as an AutoSync 
folder, and click OK. 

To maximize the ef�ciency and speed of the 
Portfolio Server, consolidate as many watch 
folders as possible into a single folder, then add 
that folder as an AutoSync folder. 

3.	In the AutoSync Settings dialog choose from the 
following options: 

Watching and Syncing Options
The Continually watch folder for changes option 
basically allows you to decide when the AutoSync 
folder is scanned for changes by the server. When 
changes are found, the folder name is highlighted in 
the Folder View window.

http://www.hornware.com/sharepoints/
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When to Sync

This option allows you to set a speci�c interval 
when items in the AutoSync (watch folder) are added 
or removed from the catalog. 

Cataloging Options
Use cataloging options preset when syncing

Check this option to use a saved preset when 
cataloging. You must have previously created 
and saved a cataloging options preset for it to be 
included in the drop down list. 

Presets that contain copy, move and rename 
functions can be chosen, but those functions 
of the preset are ignored. So basically, only the 
property assignments (�eld names, descriptions 
and keywords) 
of a cataloging 
options preset are 
used. If a saved 
preset does not 
contain property 
assignments, it is 
not available as a 
choice from the 
drop down box.

For detailed 
instructions 
about creating 
and saving 
a cataloging 
options preset, see 
the Setting Up 
Portfolio chapter 
of the Portfolio 
User Guide. 

When Originals are not Found for 
an Item in the Catalog:

This option allows you to decide whether to keep or 
delete items in a catalog when original �les can no 
longer be found by AutoSync process. 

Folder Sort Settings

The Folder Sort Settings tells Portfolio how to 
sort the display when your �rst open the folder. 
You can choose to sort the items by any �eld, or 
to apply the current custom sort for this folder. 
If you choose to apply the current custom sort, 
any custom sort that you have created will be 
applied to the folder at the catalog level. 

5.	Click OK to accept the AutoSync Settings, and OK to 
create the AutoSync folder.

Changing AutoSync folder settings
After you create an AutoSync folder, it is easy to 
change the AutoSync settings. 

If you do not have network permission to access 
an AutoSync folder, you will see the watch 
folders and cataloged thumbnails but may  
not be able to preview or otherwise open any  
of the �les.

1.	In the Folder list, click to select the AutoSync folder.

2.	Click the AutoSync Settings button  at the top of 
the Folder View pane. 

3.	Change the desired settings in the AutoSync Settings 
dialog box and click OK.
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Stopping an AutoSync process
To stop an AutoSync process, you can either remove 
the AutoSync folder from the served catalog, 
or unserve the catalog. Doing either stops the 
synchronization process. 

If you removed the AutoSync folder, you can 
re-add the folder to the catalog, and restart the 
synchronization at your convenience.

If you unserved the catalog, when you re-
serve the catalog AutoSync automatically 
resumes, starting at the point where it 
was when you unserved the catalog.

AutoSync folders and local paths
When adding an AutoSync folder that is on the same 
machine as your current Portfolio client, Portfolio 
will present you with a number of share selection 
options. All of the share selection options are valid 
paths to the new AutoSync folder. Choose the share 
path that is most appropriate for your setting. 

Server-only shares
If you want to allow clients access to the 
original �les contained in AutoSync folders, 
it is best to avoid adding folders that are 
contained in server-only shares. Users will 
only have access to item thumbnails, preview 
�les, and properties metadata for items that 
are cataloged through server-only shares. 

AutoSync folders local to Portfolio Server
Adding AutoSync folders that are on the same 
physical machine as Portfolio Server limits the 
amount of network traf�c necessary to synchronize 
these folders. So, when shares are created on the 
same machine and then added as AutoSyncfolders, 
the synchronization speed of those folders is 
far superior to non-local AutoSync folders. 

Duplicate share names
Avoid adding shares that have the same name, but 
different target directories. For example, you may 
have two shares each named �pictures,� one pointing 
to C:/mystuff/pictures/ and the other pointing 
to C:/documents/pictures/. Due to internal 
prioritization of the operating system and Portfolio 
Server, you could get unexpected results. 

Share types and when to use them

Share  
Type

Description When to use

AFP A share based on the 
Apple File Protocol. 
This is the native �le  
sharing method  
for Mac OS X.

Use AFP if you are in 
a Macintosh or mixed 
Macintosh environment. 
You may need to enable 
Services for Macintosh 
on your Windows based 
server.

SMB A share based on the 
Samba Protocol.  
This is a cross-plat-
form sharing method  
usable with Macin-
tosh, Windows and 
Unix/Linux. 

Use SMB in a mixed  
platform environment. 
SMB has a more restric-
tive naming convention 
than AFP and does not 
communicate some �le 
properties such as cre-
ated and modi�ed dates.

Local 
Drive

Share based on a  
local volume.

Use this option only if 
users can mount an  
entire server volume.  
This option is mainly 
intended for testing.

Server 
Only

This is a special type 
of share to which  
only Portfolio Server 
has access. This can 
be con�gured via  
the server �le 
con�guration.txt

Use this option to allow 
Portfolio Server to watch 
a local folder without it 
being con�gured as a 
network share. This is 
rarely used and prevents 
remote clients from ac-
cessing original �les.



13

User GuidePortfolio SQL Connect

Welcome to Portfolio SQL Connect 

Portfolio SQL Connect (sold separately) allows 
Portfolio Server to store data in relational databases, 
such as  Microsoft SQL Server, MySQL and Oracle, 
and to access those records from Portfolio.

Once the SQL database is set up, and Portfolio SQL 
Connect and Portfolio Server are running, accessing 
and administering the catalogs is the same as if 
the catalogs were created and stored directly on a 
Portfolio Server.

System and Software Requirements

Portfolio SQL Connect is a scalable solution that 
can offer enhanced functionality for a single user 
and expand to serve multi-user environments with 
constantly changing database entries.

The minimum requirements on the following page 
are based on a standard installation of one server 
with four clients connecting to that server. In 
general, the more processing power, RAM and disk 
speed available, the faster your interactions with the 
SQL database will be. There are a few installation 
con�gurations that can require more powerful 
hardware. These include:

�	Additional client connections above the standard four 
connections.

�	The installation of Portfolio Server on the same physical 
machine that contains the assets. 

�	The installation of the SQL database engine on the same 
machine as Portfolio Server. 

�	Using the powerful, yet processor intensive AutoSync 
feature of Portfolio Server can require large amounts of 
processor power and memory.

�	Running a NetPublish Server on the same physical 
machine as Portfolio Server.

If your con�guration requires any of the previous 
items, be sure to use the recommended requirements 
as your minimum requirements.

Extensis Integration and Consulting Services can 
provide support for issues not covered by the 
standard Extensis Technical Support, including: 
setting up an SQL database, con�guring TCP/IP 
Services, setting up DSN services, con�guring 
a �rewall, and other networking issues. Please 
contact Extensis Corporate Sales for details. 
For additional assistance with these issues, 
please consult your System Administrator or 
the product vendor�s technical support.

Portfolio SQL Connect
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Windows System Requirements Macintosh System Requirements
Minimum Hardware Requirements Minimum Hardware Requirements

�	CPU: 1 GHz Pentium 4 or equivalent

�	RAM: 1 GB

�	CPU: 1 GHz or faster G4, G5 or Intel Core processor(s)

�	RAM: 1 GB

Recommended Hardware Requirements Recommended Hardware Requirements

�	CPU: Dual 2.8 GHz Pentium 4 or equivalent 

�	RAM: 2 GB

When assets are kept on the same machine 
as Portfolio Server, Extensis recommends disk 
hardware that provides fast disk access, such as a 
hardware RAID array.

When Portfolio Server is installed on the same 
machine as the SQL database engine, the more 
processing power, RAM and disk speed available, 
the better.

�	CPU: Dual 2.0 GHz or faster G5 or Intel Core 
processor(s)

�	RAM: 2 GB

When assets are kept on the same machine 
as Portfolio Server, Extensis recommends disk 
hardware that provides fast disk access, such as 
a hardware RAID array.

When Portfolio Server is installed on the same 
machine as the SQL database engine, the more 
processing power, RAM and disk speed available, 
the better.

Software Requirements Software Requirements

�	Microsoft Windows 2000 Server Service Pack 3 or  
Server 2003 Service Pack 1

�	Microsoft SQL Server 2000 
SQL Server ODBC driver v2000.86.1830.00

�	Microsoft SQL Server 2005 
SQL Server ODBC driver v2005.90.1399.00

�	Oracle 9i or 10g 
Oracle ODBC driver v10.01.00.31 or v10.02.00.01

�	MySQL 4.1.20  
MyODBC Connector v3.51.11 or 3.51.12

�	TCP/IP Services installed

�	For cross-platform environments, Extensis 
recommends that Services for Macintosh (SFM) be 
installed.

Newer database engines and ODBC drivers may 
function properly, but have not been veri�ed. 
Use alternate or newer database engines and 
ODBC drivers at your own risk. 

�	Mac OS X Server (10.4.4 or higher)

�	MySQL 4.1.20

� MyODBC 3.51.12 for PowerPC-based systems

�	A specially con�gured MyODBC driver is currently 
required for proper installation on Intel-based systems. 
To obtain this driver, contact your Extensis Priority 
Support Representative. See your Annual Service 
Agreement (ASA) for contact information. 

Newer database engines and ODBC drivers may 
function properly, but have not been veri�ed. 
Use alternate or newer database engines and 
ODBC drivers at your own risk. 

For detailed MySQL installation and  
setup instructions on Mac OS X, please see the  
Portfolio8_Installing_MySQL.PDF �le  
on your install disk, or download the most 
current document from our website:  
http://www.extensis.com/downloads/

http://www.extensis.com/downloads/
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Setting up the ODBC drivers and DSN 
on Microsoft Windows

Before you can access catalogs through Portfolio, 
you must verify that you have the correct ODBC 
drivers installed on the machine that will be 
running Portfolio Server. Then you�ll need to set 
up the SQL database. When that is done you can 
install both Portfolio SQL Connect and Portfolio 
Server software. There is no direct user interface 
in either of these Portfolio products. SQL Connect 
requires no user interface, and the Portfolio 
Server is accessed and administered remotely 
using standard Portfolio application software. 
To help simplify SQL database administration, 
you can perform many common tasks with 
the included database administration tool.

For detailed MySQL installation and  
setup instructions, please see the  
Portfolio8_Installing_MySQL.PDF �le  
on your install disk, or download the most 
current document from our website:  
http://www.extensis.com/downloads/

To set up the SQL Server:

1.	On the SQL database computer,  
create a new SQL database. 

	 This task varies from one SQL database engine to 
another. Please refer to the user documentation 
provided with the SQL database engine for guidance. 

2.	On the machine housing the database engine,  
create an administrative user for the database. 

	 SQL Server 2000: A user with administrative rights 
must be created for this database. This can either 
be the standard �sa� account, or another user with 
database owner (dbo) rights. Make sure the �master� 
database is the default database for the dbo that you 
create. 

Portfolio Server supports the use of Microsoft 
Windows Authentication. To enable this ability, 
�rst stop the Portfolio Server Service. Open the 
Con�guration.txt �le located in the Portfolio 
Server Files directory. Remove the comment (#) 
from the start of the following line: 
#AllowWindowsAuthentication=yes 

Save the con�guration �le and restart  
Portfolio Server.

	 Portfolio Server creates one connection per user 
per database. Increase the maximum number of 
concurrent connections allowed by the system, 
if necessary. For example, if you are serving two 
Portfolio SQL catalogs from one SQL server, and each 
database has 50 users connected (even if they are the 
same set of users in each case) you need at least 100 
concurrent connections to the SQL server.

	 Oracle 9i and 10g: The administrative user that you 
create must have the DBA role assigned to it. 

3.	Install the Correct ODBC Drivers on the machine 
which will run Portfolio Server and SQL Connect. 

	 SQL Server 2000: Install the ODBC and SQL Server 
drivers according to the instructions supplied with 
Microsoft SQL Server. 

	 Oracle 9i and 10g: Install the Oracle Client software 
(including ODBC and Oracle driver options). In the 
ODBC Control Panel, create a System DSN with 
the user name you created in step 2. Make sure the 
Force Retrieval of Long Columns option is checked 
(enabled). 

	 When the ODBC driver is veri�ed (and the DSN 
created if this is an Oracle database) you can proceed 
with the installation and setup of Portfolio SQL 
Connect and Portfolio Server.

http://www.extensis.com/downloads/
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For an Oracle implementation, be sure to use the 
most current Oracle ODBC drivers. Download 
current drivers from the Oracle website: 
http://www.oracle.com/technology/software/
tech/windows/odbc/index.html 
The default Microsoft ODBC drivers are not 
compatible with SQL Connect. 

To create a DSN in Oracle:

1.	Choose Start > Control Panel > Administrative 
Tools > Data Sources (ODBC) to open the  
ODBC Data Source Administrator dialog box.

2.	In the ODBC Data Source Administrator dialog box, 
select the System DSN tab. 

3.	Click Add.

4.	In the Create New Data Source dialog box, select 
the Oracle ODBC Driver.

5.	Click Finish. 

6.	In The Oracle ODBC Driver Setup dialog box, enter 
the following information: 

	 Data Source Name: The name of the DSN you  
are adding. 

	 Service Name: The name of the Oracle instance, 
usually in the format �databasename.domain�.  
Check with the Oracle Database Administrator  
for the correct name. 

	 UserID: A valid user ID for the Oracle database. This 
person must have database ownership rights.

	 Force Retrieval of Longs: On the Workarounds Tab, 
enable the Force Retrieval of Longs option.

	 All other �elds: For the remaining �elds, accept the 
default settings. 

7.	Click OK to accept the changes and add the DSN.

http://www.oracle.com/technology/software/tech/windows/odbc/index.html
http://www.oracle.com/technology/software/tech/windows/odbc/index.html
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Installing Portfolio SQL Connect
Portfolio SQL Connect is installed by the 
Portfolio Server installer. If you did not 
choose the SQL Connect option when you 
installed Portfolio Server, run the installer 
again and choose the appropriate option. 

SQL Connect has no interface itself, yet advanced 
database administration functions can be 
performed through the database administration 
tool described later in this guide. Basic access 
to Portfolio Server is handled through the 
standard Portfolio application software. 

Before you can perform any Portfolio SQL 
Administration operations, the SQL database must 
be set up, Portfolio SQL Connect and Portfolio 
Server must be running on the server machine, and 
the Portfolio application must be running on the 
machine from which you wish to access the Server.

Serving an SQL Database as a 
Portfolio Catalog

Before serving an SQL database, the Portfolio Server 
that serves the SQL database must be added to the 
list of servers. See the Portfolio Server chapter of this 
guide for instructions about how to add a server. 

To serve an SQL database (catalog):

1.	In the Portfolio client application, choose  
File > Administer Servers. The Administer Servers 
dialog is displayed. 

If no server appears on the list, add your server 
to the list (see the Portfolio Server chapter of this 
guide). 

2.	From the list of Portfolio Servers, select the Server 
that you will be using to serve the SQL catalog, then 
click Administer... 

The �rst time you access a Portfolio Server as the 
Administrator, you are prompted to serialize the 
Server. When prompted, enter your SQL Connect 
Serial Code. This code is typically located on 
the product media, or was provided via email 
if you purchased electronically. See detailed 
serialization  instructions in this chapter. 

3.	Enter the Administrator password for the Portfolio 
Server, then click OK.
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	 The �rst time Portfolio Server is accessed by the 
Administrator, the password is blank. Enter a 
password, or just click OK to set the password later. 

	 The Server Administration dialog for the selected 
Portfolio Server is displayed. Any catalogs already 
being served are listed, including any active users.

	 If no catalogs are being served on this Portfolio Server 
(which is typically the case the �rst time you set up an 
SQL Server), the list is empty. 

4.	Click the Serve SQL button. The Serve SQL 
Database dialog box is displayed. If no SQL Server 
has been set up (such as the �rst time you set up an 
SQL Server), the list is empty.

5.	Click Add Server.

6.	In the Add Server dialog box, select the appropriate 
ODBC driver from the drop-down menu.
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7.	Enter a Server Name (this should be a different name 
than the name you gave the Portfolio Server) and the 
IP address of the SQL or Oracle Server.

Portfolio supports the use of IP addresses or DNS 
names in the IP Address �eld. 

For MS SQL Server, named instances can also be 
used in the IP Address �eld. Enter the IP Address 
or DNS name followed by a backslash then 
the named instance in the IP Address �eld. For 
example: 10.1.5.1\MyInstance.

8.	Enter a User Name and Password for the SQL Server. 
This can be the same name and password that you 
used for SQL Database administration, but you can 
use a different name and password for SQL Server 
administration if you prefer.

You can also connect as a �trusted� user via 
Windows Authentication. To do so, you must 
�rst modify the SQL Connect con�guration �le, 
and then enter �trusted� in the User Name �eld. 
See the instructions in the Con�guration File 
section of this chapter for details. 

9.	Click OK.

	 The SQL Server name, and any SQL Databases 
(catalogs) that you set up on that SQL Server are 
displayed in the list. The next step is to serve the  
SQL catalog.

10. In the Serve SQL Database dialog box, click to 
highlight the SQL database (catalog) that you wish to 
serve and click Serve SQL.

11.	Portfolio asks if you want to always serve this catalog 
when the Portfolio Server starts. 

	 This allows you to serve the SQL database 
automatically each time Portfolio Server is launched.

12. In the Enter Logon Information dialog box:

�	 For Microsoft Windows: enter the User Name 
and Password that you created as the SQL 
database administrator.  This must be the same 
user name and password that you entered as the 
database owner (dbo).

�	 For Mac OS X: enter the username you used in 
the keywords section when creating the DSN. 

13. Click OK. The catalog is opened in Publisher mode. 

14. You can now administer and use the catalog just as 
you would any other Portfolio catalog.
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