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Using XMP to drive your workflow

As a creative professional, you need to always have your 

important files at your fingertips. Using Extensis Portfolio 

meets that need by helping you stay organized, allowing you 

to quickly find files when you need them. To help you extend 

this organizational work, Portfolio supports Adobe’s Extensible 

Metadata Platform (XMP). This technology allows you to 

embed data about your files directly into your source files from 

any Adobe application, and subsequently read that data with 

Portfolio or any other application that supports XMP. 

This technical brief describes how to integrate XMP into 

your daily workflow, and gives you the details about setting 

everything up to function properly. 

What is XMP?

First things first, just what exactly is Adobe’s Extensible 

Metadata Platform? This labeling technology is also known as 

XMP and allows metadata to be embedded directly into the file 

itself. File Information such as descriptive text, keyword values, 

and other information then travels along with a file whereever 

it may be opened. Any metadata aware application such as 

Portfolio 8 can read the embedded metadata. 

The XMP language is based on an XML structure which makes 

it highly readable and easy to write. XMP is used extensively 

by Adobe applications as well as several standards including 

Dublin Core and IPTC4XMP. It is an open language and 

allows users to customize the metadata that is embedded into 

supported file types.
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XMP is routinely used to store metadata such as keywords and descriptions, but can also store 

custom information such as job name, product sku, etc. This custom information can be read by 

Portfolio, and it’s easy to inject and view your own information via XMP custom panels inside of 

most Adobe applications. 

Using Portfolio as a tracking tool

Before we dig into the technical side of setup, it’s good to understand how XMP can fit into your 

workflow. An emerging use for Extensis Portfolio is to use it as a workflow tracking tool. By teaming 

up several of Portfolio’s features you can create an efficient workflow that includes tracking detailed 

project information including routing, approvals and even to-do lists. As an example, let’s examine 

a sample workflow for an advertising agency. The agency has account reps, designers, production 

artists and a creative director. The agency needs to be able to know the status of each job, who is 

working on what and what assets belong to each project. 

For this example, the agency starts the process by defining the information that they need track. 

This information includes: client name, job name, job status, if the file is approved, who approved it, 

what work needs to be done, who the file is routed to and any notes to the routed person. In order 

to track this information a number of custom fields are created in the agency’s Portfolio catalog. For 

some of these fields, like Job Status, the administrator can create a pre-defined list of states like 

“ready for proof” or “in production,” which can be easily set from a drop-down menu. 

To continually track the status of custom fields in Portfolio, smart galleries can be used. When 

a smart gallery is opened, the gallery automatically finds files that contain specific custom field 

settings. For example, a smart gallery can be created for each step in the Job Status field. As 

agency members manipulate a file, they can update the file’s status by changing the Job Status 

custom field. When the custom field status changes, the file is automatically included in the smart 

gallery associated with the new status. This allows the creative director to open a single gallery and 

see all of the files at that stage in the production cycle. 

Users can also create smart galleries for to fit their own needs. Common uses could be inboxes 

or to-do lists. For example, using the Routed To custom field, a smart gallery can automatically 

search that field, and display all items that are routed to a specific user.
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To further refine the data displayed in the smart galleries, custom views can be created that display 

the most important information. For example, a custom view named “workflow” that displays all of 

the custom fields at the same time can be applied as the default view for each smart gallery. This 

means that whenever a user opens one of the smart galleries, only the most relevant information is 

displayed. So, a smart gallery that is set to locate all files where Job Status is “in-production” would 

use the custom view to display the client’s name, what work needs to be done and to whom the file 

is routed.

After setting up the smart galleries and custom views, it is at this point where custom file info panels 

can be created. These info panels (or XMP custom panels) are accessed directly from Adobe 

applications, such as Photoshop or InDesign. These custom panels allow users to update custom 

fields directly from the File Information dialog boxes, without opening Portfolio. XMP custom panels 

must be installed into the proper location on each user’s machine, and configured so that Portfolio 

extracts the information into the correct fields.

By combining custom fields, smart galleries, custom views, XMP custom panels and the metadata 

extraction abilities of Portfolio, an effective project tracking and management system can be 

created. This system allows workgroups to share files, track progress and route files for approval. 

To get you started, Extensis has created a number of Portfolio sample catalogs that include pre-

configured smart galleries, custom views and XMP custom panels. The General Production 

sample catalog and XMP panel is pre-configured for the example just described. Sample catalogs 

and XMP custom panels can be downloaded from the Extensis website http://www.extensis.com

The following pages detail the steps necessary to create custom file info panels, configure your 

Portfolio catalogs appropriately, and use Adobe Bridge to modify multiple files at once. For more 

information about smart galleries and custom views, please reference the Portfolio User Guide and 

the HTML Help system in Portfolio.

http://www.extensis.com
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Creating and implementing an XMP custom panel

To use an XMP custom panel, there are a few necessary steps that you must follow:

1.	 Create the panel from scratch, use a third party tool, or modify a currently existing custom panel.

2.	 Install the panel in the appropriate locations on users’ machines. 

3.	 Add custom XMP metadata to a test file using the new XMP custom panel.

4.	 Create the necessary custom fields in Portfolio and map the import of XMP metadata fields to the 
appropriate fields.

5.	 Use the test file to verify that the installation works properly and that the metadata fields are 
mapped to the appropriate custom fields in your catalog.

Step One: Create the XMP custom panel

XMP custom panels can be created from scratch, by third party tools, or from an existing file. 

Extensis offers three sample catalogs that include XMP custom panels. The sample XMP custom 

panels may be altered or used as a starting point for creating your own panel. As a starting point, 

Extensis recommends modifying the sample XMP custom panels. 

When creating an XMP custom panel from scratch or editing an existing file, you can use any text 

editor. For example, you can use Notepad (Win) or TextEdit (Mac) and save your results as a plain 

ASCII text file. The file must be saved with either the .TXT or .XMP filename extension.  

Note: Do not save the file with RTF file formatting.

For complete details about creating an XMP custom panel from scratch, as well as the command 

dictionary necessary to modify existing panels please refer the Adobe guide to creating XMP Custom 

File Info Panels: http://partners.adobe.com/public/developer/xmp/sdk/topic_cust_file_info_panels.html

If you choose not to modify an existing template, the following text can be used as the starting point 

for creating an XMP custom panel from scratch:

http://partners.adobe.com/public/developer/xmp/sdk/topic_cust_file_info_panels.html
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<?xml version=”1.0”>

<!DOCTYPE panel SYSTEM “http://ns.adobe.com/custompanels/1.0”>

<panel title=”$$$/CustomPanels/Panels/Extensis/PanelName=Portfolio Workflow” 
version=”1” type=”custom _ panel”>

group(placement: place _ column, spacing: gLargeSpace, horizontal: align _
fill, vertical: align _ top) {

group(placement: place _ row, spacing: gSpace, horizontal: align _ fill, 
vertical: align _ top, reverse: rtl _ aware) {

static _ text(name: ‘$$$/CustomPanels/Panels/extensis/
AssetStatus=Asset Status’, font: font _ big _ right, vertical: align _
center);

popup(items: ‘$$$/CustomPanels/Panels/Extensis/Asset Status=01 
UnEdited{01 UnEdited};02 Re-Edit{02 Re-Edit};03 Color Correct{03 Color 
Correct};04 Proof{04 Proof};05 Copyright{05 Copyright};06 Final{06 
Final};07 Complete Go Live{07 Complete Go Live};08 Archived{08 
Archived};DO NOT USE{DO NOT USE};’, xmp _ ns _ prefix: ‘extensis’, 
xmp _ namespace: ‘http://ns.extensis.com/extensis/1.0/’, xmp _ path: 
‘AssetStatus’);

}

}

</panel>

To use one of the sample XMP custom panels, download the sample catalogs files from the 

downloads section of the Extensis website: http://www.extensis.com/downloads/  

The sample catalogs ZIP file includes three sample catalogs, matching XMP custom panels as well 

as tutorial files about how to install and use each sample. The agency example at the beginning of 

this document uses the General Production sample catalog and XMP custom panel.

A third party tool can also be used to create an XMP custom panel. Pound Hill Software offers a 

number of applications that can help you create your initial XMP custom panels. The free, yet limited 

MetaSampler application allows the basic creation of a simple XMP custom panel.  

To create XMP custom panels that contain more complex and extensive metadata, you may wish to 

purchase their MetaGrove™ Developer application. 

The free MetaSampler application can be downloaded from: http://www.poundhill.com/

http://www.extensis.com/downloads/
http://www.poundhill.com/
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Step Two: Install the XMP custom panel on users’ machines

For users to be able to access the XMP custom panel from within Adobe software products, the .TXT or 

.XMP file for the panel must be placed in the appropriate locations on users’ machines. The files must be 

placed in either of the following locations depending upon platform:

¢	 Mac OS X:  

{Root Volume}/Library/Application Support/Adobe/XMP/Custom File Info Panels

¢	 Windows: 

\Program Files\Common Files\Adobe\XMP\Custom File Info Panels

If the files are not installed in the appropriate locations, when the File Info dialog box is opened in any 

Adobe application, the new XMP custom panel will simply not be displayed.

Step Three: Add test metadata to a file using the new XMP custom panel

Before moving onward, create a test file to which you can add metadata that can be extracted in  

future steps. 

1.	 Open a test .JPG file in Adobe Photoshop

2.	 Choose File > File Info

3.	 Choose the name of your  
	 custom info panel from the  
	 list on the left. In this example,  
	 we kept the name from the  
	 General Production sample  
	 panel. 

4.	 Enter sample data into each  
	 metadata field.

5.	 Click OK to dismiss the File  
	 Info dialog box.

6.	 Save and close the test file. 
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Step Four: Create and map custom fields in Portfolio

After creating your XMP custom panel, you need to add custom fields to your catalog that match the 

metadata fields in your panel. 

To add a custom field to a catalog:

1.	 Change your access level to Administrator mode. 

	 Choose Catalog > Access Level, change the Catalog Access level to Administrator and enter the 
password if necessary, then Click OK. 

	 Note: For catalogs served by Portfolio Server, no other users may be logged in to the catalog while 
adding custom fields. 

2.	 Choose Catalog > Custom Fields.

3.	 In the Custom Fields dialog box, click New. The New Field dialog box is displayed.

4.	 Enter a name for the field in the Name text box (i.e. Asset Status)

5.	 Choose the field type.

	 The field type determines the values that can be entered into this field. The most commonly used 
field type for custom applications is Text. Field types cannot be changed once they are defined. See 
the Portfolio User Guide for complete details. 

6.	 Select the appropriate remaining options for the field type you selected. If you would like to use a 
predefined list, select the predefined list option and create the list. Click OK to return to the Custom 
Fields dialog box. .

7.	 When you have finished adding Custom Fields, click OK.
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After creating the custom fields, you need to tell Portfolio what metadata fields to expect, and where to store 

the data in the catalog for files that contains the new metadata. Keep the list of fields included in your new 

XMP custom panel handy for reference while implementing the new fields and mappings in Portfolio. 

To create a new metadata field:

1.	 In the Advanced Cataloging options dialog box, on the Properties tab, click the Settings button.

	 – or –

	 Choose Catalog > Metadata Settings.

2.	 In the Metadata Properties Settings 
dialog box, click the Edit Metadata 
List button.

3.	 In the Metadata List dialog box, click 
New.
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4.	 Enter a new Metadata Name (i.e. Workflow – Asset Status) and Metadata Field  
(i.e. extensis:AssetStatus). The syntax is namespace:fieldname

5.	 Click OK to save your changes to the Metadata List.

After adding all of the new Metadata fields, change the field mapping so that the metadata in your XMP 

Custom Palette is placed in your new custom fields when you catalog the files. 

To change a field mapping:

1.	 In the Advanced Cataloging options dialog box, on the Properties tab,  
click the Settings button.

	 – or –

	 Choose Catalog > Metadata Settings.

2.	 In the Metadata Properties Settings dialog box, on the Extracting Data tab, click to highlight the 
specific Metadata to Extract field to update (i.e. Workflow – Asset Status).

3.	 On the right hand side of the dialog, click the corresponding Catalog Field to change (i.e. Asset 
Status).
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Step Five: Verifying the new XMP custom panel

After adding and mapping the new metadata fields, you are ready to extract the information from 

your test file. If your test file has already been added to your Portfolio catalog, you need only update 

the file to add the new metadata from the XMP custom panel. Files already in your catalog must be 

manually updated to reflect changes in metadata made via any Adobe application. To have your files 

automatically updated, use the FolderSync or AutoSync feature. See page 78 of the Portfolio User 

Guide for complete details. 

To update an already cataloged file:

•	 Select the test file in your catalog and choose Item > Update

If the test file isn’t already in your catalog, add it to your catalog. Because you have already configured 

your metadata mapping, when the test file is cataloged the appropriate custom fields will automatically 

be populated. 

To verify that the test file contains the new data:

1.	 Choose Item > Item Properties

2.	 In the File Info dialog box, select the Fields tab. Verify that the correct  
field information has been updated or created
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Further automation with Adobe Bridge

After creating your XMP custom panel and properly configuring your Portfolio catalog, you can enter 

metadata directly from the File Info dialog box of any Adobe application. Using the metadata template 

feature in Adobe Bridge, you can append or replace metadata in multiple items at the same time. 

To append metadata using Adobe Bridge:

1.	 Launch Adobe Bridge

2.	 Select an item for which to update metadata.

3.	 Choose File > File Info

4.	 Select your XMP custom panel from the list on the left. Enter or change any desired metadata.

5.	 From the upper right-hand corner of the File Info dialog box, click the arrow and choose Save 
Metadata Template

	 This saves all of the current XMP settings as a template that can be applied to any other item 
recorded in Bridge. 
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6.	 In the Save Metadata Template dialog box, enter a template name and click OK.

7.	 Click OK save the XMP information to the current file and dismiss the File Info dialog box. 

8.	 At this point, select the items to update the Adobe Bridge main window.

9.	 Choose Tools > Append Metadata > <template name> to append the metadata in your 
template to the selected items.

	 – or –

	 Choose Tools > Replace Metadata > <template name> to replace the metadata in the selected 
items with all of the metadata contained in your template. 

	 Note that the Replace Metadata command will write blank fields over those that already contain 
data and may have undesired consequences. 

The last word

For product updates, the most current sample files and answers to technical issues, please visit the 

Extensis website: http://www.extensis.com
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