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What’s New

Portfolio 8.5 includes a number of new features 
that will help speed up your workflow, and make 
it easier to use the entire Portfolio product line. 
This document covers all products updated in this 
release.  

Portfolio client and Single-user
The Portfolio client and single-user application 
includes new features as well as updated operating 
system compatibility.

•	Catalog types – When creating a new catalog, 	
Portfolio now allows you to configure a catalog from a 
number of preconfigured settings.

•	Default field values – When adding new items to a 
catalog, you can now determine that if no other value is 
chosen or extracted, specific fields will always start with 
a default setting.

•	Presets Palette – This palette allows you to assign 
a number of properties simply by clicking assign or 
dragging a preset onto the item. This includes mass 
updating keywords, description and custom field values. 

•	Microsoft Windows Vista compatibility.

•	Adobe Illustrator and InDesign CS3 file 
compatibility.

•	Support for new digital camera Raw formats.

•	 Improved EPS and PDF file-format support.

Portfolio Server & SQL Connect
Portfolio Server has been updated for performance 
and improved SQL database support. 

•	AutoSync has been improved so that folders synchronize 
more quickly and reliably.

•	Portfolio SQL Connect support is expanded to include 
Microsoft SQL Server 2000 & 2005, MySQL 4 & 5 and 
Oracle 10g R2

Portfolio NetPublish
NetPublish 8.5 includes an image watermarking 
feature and download log.

•	 Image watermarking allows you to protect your images 
(JPG, GIF, PNG, BMP) from unauthorized use by placing 
a watermark on the file.

•	The enhanced assets log allows you to know which 
of your cataloged items are being accessed and 
downloaded from your NetPublish site.

Portfolio Project Sync
Portfolio Project Sync directly connects an AutoSync 
folder in a served catalog to Adobe Version Cue 
CS3 Clients, that are built into applications like 
Illustrator, InDesign, Photoshop and Bridge. This 
allows you to access your Portfolio assets directly 
from most Adobe CS3 applications without ever 
opening the Portfolio client. 

See the Portfolio Project Sync User Guide for 
complete installation, configuration and usage 
information.

Introducing Portfolio 8.5
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Registration and Personalization

It is important to register your copy of Portfolio  
so that we can provide you with the best possible  
service. Registered users of Portfolio are eligible 
for technical support, information regarding new 
versions and products, as well as discounts and 
special offers. 

Your serial number is located in one of three 
locations: on the Portfolio CD sleeve, on the product 
packaging, or was sent to you via e-mail if you 
purchased through our website. Enter that number 
to personalize your copy of Portfolio. 

If you choose not to personalize your copy, Portfolio 
runs in a demonstration mode that allows you 
to use the product for 30 days. You can purchase 
additional serial numbers from Extensis. See the 
contact page at the beginning of this guide for 
contact and purchase information.

Technical Support

Technical Support is available directly through the 
Extensis web site. Please fill out the online support 
form at http://www.extensis.com/support/ to get support.  
Our tech support representatives will respond by 	
phone or e-mail, usually within 24 hours on 
weekdays. 

When contacting technical support, include the 
following information: 

• Your Portfolio serial number

• Your computer configuration

• Your question or a description of the difficulty you’re 
experiencing - what specifically occurs and when 

•	Your phone number if you wish to have our 
representatives call you 

Take note of any displayed error numbers or 
messages and any other information you think may 
be relevant.

For answers to frequently asked questions and 
troubleshooting tips, you can also visit the Portfolio 
page on the Extensis web site:

http://www.extensis.com/portfolio/  

Annual Service Agreements
If you have purchased an Annual Service 
Agreement, you are entitled to priority technical 
support. Please call the number listed on your 
agreement form for the fastest possible service. 

About this Guide

This guide covers only the items updated in 
Portfolio 8.5, Portfolio Server 8.5, Portfolio SQL 
Connect and Portfolio NetPublish 8.5 and is 
supplemental to the version 8.0 documentation 
which was not updated in this release. Information 
in this guide supersedes any other instructions 
included in other guides.  

http://www.extensis.com/support/
http://www.extensis.com/portfolio/
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Portfolio 8.5 client and single–user 
New Features

Portfolio 8.5 includes a number of new features 
that are designed to help speed up your workflow. 
Each of the following features are described in this 
chapter. 

•	 catalog types

•	Presets Palette

•	Default field values 

•	Microsoft Windows Vista compatibility

•	Adobe InDesign and Illustrator CS3 file compatibility

•	Support for new digital camera Raw file formats

•	 Improved EPS and PDF file format support

System and Software Requirements

To install and use Portfolio 8.5, you’ll need the 
following minimum hardware and software:

Portfolio Macintosh:
•	Mac OS X (10.4.4 or higher)

•	1GHz or faster G4, G5 or Intel Core processor(s)

•	256MB of available RAM

•	500MB of available hard disk space (additional space 
may be required for database and asset storage)

• QuickTime 7 or higher 

•	1024 x 768 or larger display

•	Network interface for Server and NetPublish connection

•	Web browser with Adobe Flash 7 or 	
higher plug-in installed

•	Adobe Reader 5 or higher

•	Microsoft Office X (10.1.9 only) for text indexing and 
thumbnailing of Office file types. Systems that are not 
used to catalog Office files can still view and search 
Office files even if Office X is not installed. 

Portfolio Windows:
•	Windows 2000 SP4, Windows XP SP2 or Vista

•	1GHz or faster processor

•	256 MB of available RAM 

•	500MB of available hard disk space (additional space 
may be required for database and asset storage)

•	1024 x 768 or larger display

•	Network interface for server connection

•	QuickTime 7 or higher 

•	Web browser with Adobe Flash 7 or 	
higher plug-in installed

•	Adobe Reader 5 or higher

•	Microsoft Office 2003 SP2 or higher for text indexing 
and thumbnailing of Office file types. Systems that are 
not used to catalog Office files can still view and search 
Office files even if Office is not installed.

Portfolio 8.5 is not backward compatible with 
previous versions, and all clients and servers 
must be running the same version. 

For upgrade versions of Portfolio, be sure to have your 
serial number for previous versions of Portfolio on hand 
while installing. 

Portfolio 8.5
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Serializing Portfolio

A serial number can be recorded for Extensis Portfolio 
when the application is launched for the first time, or 
at any other time using the Enter a New Serial Number 
command. You may need to do this if you upgrade from 
the single-user version of Portfolio to client version.

To enter a serial number:

•	 The first time you launch Portfolio, the Serialize 
Portfolio dialog box automatically opens.  
Enter a valid serial number and click Continue. 

– or – 

1.	Choose Help > Enter New Serial Number (Win)

or choose Portfolio > Enter New Serial Number (Mac)

2.	Enter a serial number and click Continue. 

Catalog types

Catalog types make it much easier and faster to 
configure a new catalog for a specific purpose. 
When creating a new catalog, there are several 
catalog types from which to choose. Each catalog 
type is basically a starting point from which you can 
further customize your catalog. 

Catalog types differ mainly in the number and type 
of custom fields included. Portfolio 8.5 allows you to 
choose the catalog type that most closely matches 
your needs. 

•	General Use

•	Movie Library

•	Office™ Documents

•	Photo Library

•	Project Sync for Adobe® Creative Suite

•	Simple

In addition to custom field and keyword settings, 
there are also other optimized settings for each 
catalog type. These settings include those typically 
configured in the Advanced Cataloging Options 
dialog box. For example, the thumbnail size used 
in the Project Sync catalog type is set at 256 pixels, 
which is the optimal size for use with Adobe Bridge.

The benefits of choosing a catalog type can be 
measured in time. Since Portfolio automatically 
creates many custom fields for you, the setup time 
required will be considerably shorter. Also, if you 
don’t need to have a large number of custom fields, 
accessing and searching for items in your catalog is 
much quicker. 

Despite which catalog type you choose at the start, 
you can add and delete custom fields and update 
metadata mappings to fit your specific needs.

It’s important to note that choosing a catalog 
type does not preclude you from cataloging all 
file types supported by Portfolio. 

To create a new catalog:

1.	Choose File > New Catalog

2.	Navigate to a disk location for your new catalog, 
enter a catalog name and click Save. 

3.	In the New Catalog dialog box, from the drop-down 
menu choose a catalog type. There are six types from 
which to choose: 
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•	 General Use - The General Use catalog type includes 
many default custom fields for a wide variety of 
metadata, including EXIF, IPTC and XMP fields. Use 
this catalog type if you want to include all of these 
fields in your catalog, or if you aren’t sure what type 
of media will be in your catalog.

•	 Movie Library — The Movie Library catalog type is 
optimized for catalogs that will include MOV, AVI and 
MPG videos, supported by QuickTime. Custom fields 
are created for extracting video-specific metadata. 
Thumbnail settings generate an image from 15 
seconds into each video. 

Catalogs of this type will only allow supported 
video formats into the catalog. All other file 
types will be ignored.

•	 Office Documents — The Office Documents 
catalog type is designed for tracking Microsoft Office  
documents in Portfolio. This is limited to common 
file formats from Microsoft Office, including Word 
(DOC), PowerPoint (PPT) and Excel (XLS). Custom 
fields are created for extracting Microsoft-specific 
metadata and text from supported file types. 

	 This catalog type also enables the full indexing of the 
text contained in cataloged assets. This allows you 
to search for words and phrases contained within 
files. Cataloging document files using this catalog 
type may be somewhat slower due to the robust text 
indexing process.

Catalogs of this type will only allow supported 
Microsoft Office file types into the catalog. All 
other file types will be ignored.

•	 Photo Library — The Photo Library catalog type 
includes custom fields for extracting embedded 
EXIF, IPTC and XMP metadata from image formats, 
including those from camera Raw files.

•	 Project Sync for Adobe® Creative Suite — The 
Project Sync catalog type is optimized for use with 
Adobe Version Cue® using the Portfolio Project Sync 
plug-in. These catalogs contain custom fields that can 
be edited directly from a file’s XMP panel, available 
from the File Info dialog, in many Adobe applications.

In order to maintain parity with embeded 
metadata, for this catalog type, keywords are 
not automatically added to Portfolio from the 
path. You may want to change this setting in 
Cataloging Options to suit your needs, but be 
aware that non-Portfolio users may not see these 
keywords, and can only view the file’s embeded 
XMP metadata.

•	 Simple — The Simple catalog type does not contain 
any custom fields, and is not configured to extract 
metadata from files. The simple catalog type is useful 
as a starting place for complex catalogs that require 
specific custom fields and metadata extraction 
settings that you want to configure manually.

	 This catalog type does contain Keywords and 
Description fields, yet can be configured to 
extract metadata into these fields. Keywords are 
automatically-generated in the catalog, based on 
path. 

3.	Click OK. 

	 Portfolio creates the new catalog. 
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You can now further customize your catalog by 
adding and removing custom field and changing 
metadata settings as necessary. 

Depending upon the types of assets that you are 
cataloging, you may also want to update the Index 
Document Text and Create Keywords from Path 
settings from the Catalog > Advanced Options > 
Properties tab. 

Creating a custom catalog type

One of the benefits of Portfolio is the ability to 
configure it to specifically fit your needs. Once 
you’ve configured all of the custom fields, metadata 
mapping, thumbnail size and such, you can save 
all of these settings into a custom catalog type. 
Once the catalog settings are saved, the new type is 
available when you create a new catalog. 

Custom catalog types are handy when used to create 
a new catalog that replicates the specific custom 
needs of a current catalog. They can also be used to 
quickly generate many new catalogs using identical 
settings.

To create a new catalog type:

1.	Customize a catalog to meet your specific needs. The 
values stored in a catalog type include:

•	Advanced Cataloging Options

•	Custom fields, including the default values and any 
predefined lists for those fields

•	Metadata Mappings

•	Master Keywords

2.	Choose File > Save Catalog Type

3.	In the Save Catalog Type dialog box, enter a name 
and description. This information is displayed in the 
catalog type list when you create a new catalog. 

Saving a catalog type with the same name as a 
current catalog type replaces the existing type.

4.	Click OK to create the new catalog type. 

Only catalog-specific settings are included. Any 
assets, galleries, categories, custom views or 
saved finds in the current catalog will not be 
retained in the catalog type. 

Due to the language-specific nature of catalogs, 
each catalog type saves catalog settings in the 
language currently in use. So, for example, to 
create an English-based catalog type, create 
and save the catalog type while using Portfolio 
in English.

Presets Palette 

The Presets palette allows 
you to update a number of 
different data fields at the 
same time by utilizing a 
cataloging options preset. 
This includes keywords, 
descriptions and an 
unlimited number of  
custom fields. 

When you are cataloging 
items manually, you are 
typically presented with the cataloging options 
dialog box. With the Presets Palette, you can 
apply the saved cataloging options configured 
with a single click after the assets have already 
been cataloged, making it easy to update massive 
amounts of metadata with a single click. 
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It’s important to note that when applying a preset, 
only the Assign Properties options are utilized. Any 
copy, move or rename options are ignored. When 
a preset is applied, changes to fields that can hold 
multiple values, such as keywords, are appended to 
the item record. Changes to single–value fields, such 
as the Description will replace the current setting in 
the catalog.

To display the Presets palette:

1.	Choose Window > Presets

To create a new preset:

1.	Choose Window > Presets

2.	Click Options

3.	In the Cataloging Options dialog box, select any of 
the Assign Properties options. 

Copy, move and rename operations are ignored 
when applied as a preset.

4.	Click Save As (Win) 

	 –  or – 

	 Choose Save As from the drop-down menu (Mac)

5.	Give your preset a name and click OK.

6. Click OK to close the Cataloging Options dialog box.

To apply a preset

1	 From the Presets palette, click and drag the preset 
name onto any single item or group of highlighted 
items in a gallery. 

	 – or –

	 Highlight any single item or group of items in a 
gallery, then in the Presets palette, highlight a preset 
name and click Assign.

2.	Click OK to assign the preset to the selected items. 

Assigning a preset cannot be undone.

Default Field Values

Default values can be specified for fields in a catalog. 
This ensures that there are always values entered 
into any custom fields where you might always want 
to have a value. 

When new files are cataloged, values may be entered 
through the cataloging options dialog box, yet 
if settings are not chosen, the default values are 
automatically recorded for the item. 

For example, if you have a Portfolio catalog for all 
of your work in progress, you might have a custom 
field called Project Status. You would set up the 
default field value for this custom field to “Draft” 
ensuring that all newly cataloged items have this 
setting, and that it is only changed to “Final” when 
you change this value later. 

Default values can also be overwritten with 
any extracted or manually-assigned value. 
Manually-assigned values include those assigned 



�

User Guide Update Portfolio 8.5

by Cataloging Options, or those applied by a 
FolderSync, AutoSync or Background Cataloging 
watch folder. 

To define default values for fields:

1.	Choose Catalog > Administration.

2.	Enter the administration password and click OK.

3.	In the Catalog Administration dialog box, select the 
Default Values tab. All of the custom fields for the 
catalog are listed on this tab.

4.	Locate the custom field for which you want to set a 
default value. Check the box to the left of the field 
name. 

	 If there is already a default value set, click the Edit 
button, otherwise the Edit dialog box automatically 
opens. 

5.	The Edit dialog box varies by the type of custom field 
that you are editing. For multi-value fields, you can 
add one or more default values, single-value fields 
only accept one default value. 

	 Enter the appropriate default value and click OK.

6.	Add any additional default values as necessary.

7.	Click OK when finished adding default values.

Fast Cataloging 

When adding items to a catalog, Portfolio catalogs 
the files in a two step process.

In the first step, all files are quickly scanned and 
added to the catalog. As files are scanned, embedded 
thumbnail files are extracted and displayed with 
a yellow dot indicating that file is only partially 
cataloged. You can browse through partially 
cataloged files without affecting the cataloging 
process. 

As files are cataloged, a progress bar is displayed at 
the bottom of the Portfolio user interface where 
you can pause, continue or cancel the cataloging 
process. Items that are not fully cataloged, can be 
opened and previewed as necessary. 

The second phase of cataloging happens in the 
background, so that you can continue to work 
in Portfolio while items are being finished with 
cataloging. 

Fast cataloging can be enabled and disabled with an 
Advanced Cataloging option (Catalog > Advanced 
Options > Thumbnails tab)
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Fast Cataloging indicator dots
Yellow dot

A yellow dot on a catalog thumbnail indicates a 
partially cataloged item. During the first cataloging 
pass Portfolio extracts any embedded thumbnails 
and previews, as well as any easily accessible 
metadata and places a yellow dot on the file. This is 
an indication that the file still requires additional 
processing by Portfolio. The yellow dot will clear 
once the second stage of processing is complete. 

Red dot 

A red dot on a cataloged item indicates that the file 
in question may be corrupt, in-use, or that the file 
permissions may be such that it is unreadable by 
Portfolio. 

The red dot can also appear if your catalog is 
configured to generate disk-previews and either the 
Previews folder cannot be found or Portfolio (or 
Portfolio Server) does not have the right permissions 
to access the folder and update the files.

Finding files by cataloging status
Portfolio makes it easy for you to locate items based 
on the item’s cataloging status. For example, if the 
cataloging process was interrupted, your catalog 
might contain a number of partially cataloged items. 

To find partially cataloged items (yellow dot):

•	 Choose Edit > Find > Partially Cataloged  
Items (Mac)

– or –

•	 Choose Catalog > Find Other > Partially Cataloged 
Items (Win)

After locating the partially cataloged items, you can 
select all of the items with this status and choose 
Item > Update to complete the cataloging process. 

To find unreadable items (red dot):

•	 Choose Edit > Find > Unreadable Items (Mac)

– or –

•	 Choose Catalog > Find Other > Unreadable  
Items (Win)

After locating unreadable items, you can use the 
Item > Original > Reveal in Finder (Mac) or Item 
> Original > Find in Explorer (Win) command 
to locate the file so that you can resolve any file-
integrity or permissions issues. 
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Portfolio Server

This release of Portfolio Server offers improvements 
on the performance of AutoSync folders.

On Microsoft Windows server platforms, updated 
image processing filters will allow certain asset types 
to catalog much more reliably and quickly. Most 
notably is improved support for EPS, PDF, Adobe 
Illustrator and InDesign formats.

In addition to performance and stability 
improvements, AutoSync folders were also updated 
to support the new Portfolio Project Sync plug-in. 
This feature allows users to access items stored in 
a Portfolio catalog directly from Adobe Bridge and 
other Creative Suite applications, without the use of 
the Portfolio client. For detailed setup, configuration 
and usage instructions, please see the Portfolio 
Project Sync User Guide.

Portfolio Server  
Minimum System Requirements

The following are the minimum system 
requirements for Portfolio Server installation. 

If you have very large database that is being 
maintained through AutoSync folders, the 
performance of Portfolio Server will be positively 
affected by faster processors and more memory. 

Portfolio Server Macintosh:
•	Mac OS X v10.4.4, including Mac OS X Server v10.4.4

•	1GHz or faster G4, G5 or Intel Core processor(s)

•	512MB of available RAM

•	500MB of available hard disk space (additional space 
required for database and asset storage)

• QuickTime 7 or higher 

•	1024 x 768 or larger display

•	Adobe Reader 5 or higher

•	Network interface with a 10 megabit or faster 
connection

•	Microsoft Office X (10.1.9 only) for text indexing and 
thumbnailing of Office file types.  

Portfolio Server Windows:
•	Windows 2000 SP4, Windows XP SP2, or	

Server 2003 SP1 or R2

•	1GHz or faster processor

•	512MB of available RAM 

•	500MB of available hard disk space (additional space 
required for database and asset storage)

•	1024 x 768 or larger display

•	Network interface with a 10 megabit or faster 
connection

•	QuickTime 7 or higher 

•	Adobe Reader 5 or higher

•	Microsoft Office 2003 SP2 or higher for text indexing 
and thumbnailing of Office file types. 

Portfolio Server 8.5 and 
SQL Connect 8.5
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Portfolio SQL Connect

To keep pace with the development of SQL  
databases, we have expanded Portfolio SQL Connect 
to support all of the following:

•	MySQL 4.1.21 or 5.0.37

•	Oracle 10gR2

•	Microsoft SQL Server 2000 SP4, 2005 SP2

MySQL 5 offers tremendous improvements in 
overall catalog performance, and is recommended as 
the preferred choice over MySQL 4. 

For a complete list of Portfolio SQL Connect system 
requirements, please see the detailed chart on the 
following pages.

It’s important to note that the SQL Server need not be 
installed on the same server as Portfolio Server. 

Upgrading a Portfolio SQL database  
to Portfolio SQL Connect 8.5

When upgrading from a previous version of a 
SQL- based catalog, you must use the SQL Connect 
Database Administration tool to update the schema 
so that it is compatible with Portfolio Server 8.5.

It’s important to note that when upgrading a 
database that you must update incrementally. If you 
are upgrading from a Portfolio 7 schema, you would 
first convert from 7 to 8, then 8 to 8.5. If you are at 
all unsure about upgrading your database, please 
contact priority technical support using the number 
listed on your Annual Service Agreement contract. 

Upgrading with the Windows DBA Tool
For Microsoft Windows-based SQL databases, 
follow the instructions listed in the Database 
Administration Tool chapter of the Portfolio Server 
User Guide to upgrade the schema. 

The included SQL Database Administration Tool 
requires the Java Runtime Environment (JRE) version 
1.5 or higher (Windows only). The JRE installer is 
placed on your hard disk in the Portfolio Server 
application folder when you install Portfolio Server. 
To install this version of JRE, run the file named:	
jre-1 _ 5 _ 0 _ 11-windows-i586-p.exe

Upgrading with the Mac OS X  
Portfolio SQL Upgrade Tool

The Portfolio SQL Upgrade Tool is installed 
automatically with any Portfolio Server Install. 

It is highly recommended that you run the Upgrade 
Tool on the same machine that contains the SQL 
database.

1.	Launch the Upgrade tool from Extensis Portfolio 
Server 8.5 > Portfolio SQL Upgrade Tool.
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2.	The tool automatically locates the default MySQL 
client directory:

	 usr/local/mysql/bin/mysql/

	 If MySQL is installed in another location click 
Browse and navigate to the new directory.

3. In the Server field, enter the location of the  
MySQL Sever. 

	 By default this field points to localhost, 
indicating the system that you are currently 
logged into, but you can also enter an IP address or 
DNS name for any other MySQL server. Though, 
for speed and data integrity issues, Extensis 
recommends that you run the upgrade tool on the 
same machine that is running the MySQL Server. 

4. The default port for MySQL Server is 3306. 

	 Update this field if your server is running on a 
different port.

5. Database is the name of the MySQL database that 
you want to upgrade. 

The Database name is case-sensitive. 

6. For the User Name and Password fields, enter the 
username and password with privileges granted on 
the MySQL database to be upgraded. 

	 This is not the password used to administer  
Portfolio Server, or user passwords within the 
Portfolio catalog. For more information on MySQL 
user accounts and permissions required for SQL 
Connect, consult the Portfolio Server user guide.

7. Click Upgrade to run the tool. The tool should take 
a few minutes to upgrade the schema, even for very 
large catalogs. 
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Portfolio SQL Connect System Requirements

Windows System Requirements Macintosh System Requirements
Minimum Hardware Requirements Minimum Hardware Requirements

•	CPU: 1 GHz Pentium 4 or equivalent

•	RAM: 1 GB

•	CPU: 1 GHz or faster G4, G5 or Intel Core processor(s)

•	RAM: 1 GB

Recommended Hardware Requirements Recommended Hardware Requirements

•	CPU: Dual 2.8 GHz Pentium 4 or equivalent 

•	RAM: 2 GB

When assets are kept on the same machine 
as Portfolio Server, Extensis recommends disk 
hardware that provides fast disk access, such as a 
hardware RAID array.

When Portfolio Server is installed on the same 
machine as the SQL database server, the more 
processing power, RAM and disk speed available, 
the better.

•	CPU: Dual 2.0 GHz or faster G5 or Intel Core 
processor(s)

•	RAM: 2 GB

When assets are kept on the same machine 
as Portfolio Server, Extensis recommends disk 
hardware that provides fast disk access, such as 
a hardware RAID array.

When Portfolio Server is installed on the same 
machine as the SQL database server, the more 
processing power, RAM and disk speed available, 
the better.

Software Requirements Software Requirements

•	Microsoft SQL Server 2000	
SQL Server ODBC driver v2000-8.00.2039

•	Microsoft SQL Server 2005	
SQL Server ODBC driver v2005-9.00.1399.06

•	Oracle 10g R2	
Oracle ODBC driver v10.02.00.01

•	MySQL Database 4.1.21 or 5.0.41	
MyODBC Connector 3.51.12

Newer database engines and ODBC drivers may 
function properly, but have not been verified. 
Use alternate or newer database engines and 
ODBC drivers at your own risk. 

•	MySQL Database 4.1.21 or 5.0.41

• MyODBC 3.51.14 

Newer database engines and ODBC drivers may 
function properly, but have not been verified. 
Use alternate or newer database engines and 
ODBC drivers at your own risk. 

For detailed MySQL installation and 	
setup instructions on Mac OS X, please see the 	
Portfolio8_Installing_MySQL.PDF file 	
on your install disk, or download the most 
current document from our website: 	
http://www.extensis.com/downloads/

http://www.extensis.com/downloads/
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NetPublish new features

Three new features were introduced in this version 
of NetPublish. They include a download log 
that allows you to know which items are being 
downloaded by site users, new download security 
settings, as well as the ability to watermark items 
contained in a NetPublish site. Each of these 
features are implemented “under the hood” and are 
not exposed in any graphical user interface.

Asset Download Log

The download log tracks a bounty of information 
about which assets are being downloaded from your 
NetPublish site. This file is named assets.log, and is 
located on your NetPublish server in the following 
locations depending upon your server OS. 

This release adds a number of helpful information 
fields to this log, and can be used to assist in 
determining who is accessing files, as well as which 
files are most frequently downloaded and so forth. 

The default installation directory on Windows is:

C:\Program Files\Extensis\Portfolio 
NetPublish Server\Web Root\app\assets.log

The default installation directory for Macintosh is:

//Boot Volume/Applications/Portfolio 
NetPublish Server/Web Root/app/assets.log

The assets.log file is a tab-delimited file that 
can be easily read by a standard text-editor or 
spreadsheet program, such as Microsoft Excel. Using 
a spreadsheet program to view the file gives you the 
option to analyze your NetPublish site traffic and 
create reports from the data.  

The following information fields are contained in 
the assets.log file in order:

• Date of the download.

• Time of the download.

• The IP Address of the machine that initiated the 
download.

• The User Login information if the site requires a login, if 
the site does not, this contains any available remote host 
data – for example, an IP Address.

• The filename of the item downloaded, including files 
downloaded as part of an archive. 

• The original source file’s pathname.

• The Portfolio ItemId of the file.

• The name of the catalog from which the item was 
downloaded.

• The NetPublish catalog alias name.

• The NetPublish site name.

• The archive filename, if the file downloaded was an 
archive.

• The height, width and aspect ratio of the file 
downloaded, if these settings were adjusted.

Portfolio NetPublish 8.5
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Watermarking and  
Asset download protection

When you watermark an image, you place a 
semi-visible mark on it, thus discouraging any 
unauthorized use.  

The type of watermark that NetPublish will place 
on a target image is considered “destructive” to 
the downloaded file, and is not like some other 
“invisible” watermarks that you may have seen. It’s 
important to note that the watermark only affects 
the downloaded file that web users access, and in to 
way alters your original assets.

You can choose any non-animated GIF image to use 
as a watermark. In general, a high-contrast, simple 
image (such as those containing text) will perform 
better than complex, low-contrast images. This file 
can be located in any easily accessible location on 
the NetPublish server. 

Currently watermarking is supported for all image 
file types that can be dynamically scaled by 
NetPublish, including JPEG, GIF, PNG and BMP.

The watermarking feature doesn’t have a specific 
user interface from which to be enabled. To use this 
feature, you need to edit the site.properties file. 
This file is generated by the NetPublish Assistant 
whenever a site is published to the NetPublish web 
server.

The default location for this file on Windows is:

C:\Program Files\Extensis\Portfolio 
NetPublish Server\Web Root\site\	
<site name>\site.properties

The default location for this file on Macintosh is:

/Applications/Portfolio NetPublish Server/
Web Root/site/<site name>/site.properties

The site.properties file can be opened with any 
standard text editor, such as Notepad on Windows 
or TextEdit on the Mac, but must retain the  
UTF-8 encoding format. The process of enabling 
Watermarking and asset download protection 
involves appending the necessary parameters to this 
file, selecting the options that you desire.

Choosing a watermark image
The watermark transparency pixel

The transparency of the watermark is determined 
by the upper-left corner pixel of the watermark 
GIF. The color of that pixel determines what is 
considered the “background” and thus transparent 
part of the watermark. It’s important to note that 
any alpha channels are ignored, and transparency is 
entirely determined by the upper left pixel. 
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Watermarking and asset protection settings
There are six settings that can be controlled from 
the site.properties file that affect watermarking 
and asset protection. The following chart gives a 
quick overview of the settings. 

setting allowed  
variables

default  
variable

archives true, false, 	
watermark

true

originals true, false, 	
watermark

true

previews true, false, 	
watermark

true

watermarkAlign center, topleft, 	
bottomleft, 	
bottomright, tile,	
fit

bottomright

watermarkOpacity 0 - 100 50

watermarkFile path to watermark 
image

none

archives

true — This is the default setting for archive files. 
This allows the NetPublish site user to download 
archive files.

false — restricts NetPublish site users from 
downloading files in an archive. When disabling 
archives in site.properties file, be sure that the 
associated site does not include a download archive 
feature, as it will no longer function.

watermark — each image is watermarked based on 
the watermark settings as it is added to the archive 
file. If there are items that cannot be watermarked in 
the archive, then the item is skipped and excluded 
from the archive. To ensure that all files added to 

an archive are always included when using the 
watermark feature, be sure that any files published 
to the NetPublish site are able to accept a watermark. 

If no files are able to accept a watermark when 
NetPublish is creating an archive, an error 
indicating “No files can be downloaded” is 
displayed to the NetPublish site user.

originals

true — This is the default setting for original files. 
This allows the NetPublish site user to download 
and view the original files on the site.

false — restricts NetPublish site users from 
accessing any original files. If the NetPublish site 
is configured to include an original image, the site 
will instead display a message indicating the images 
cannot be rendered.

watermark — each original image is watermarked 
based on the watermark settings before it is provided 
to the NetPublish site user.

previews

true — This is the default setting for preview files. 
This allows the NetPublish site user to download 
and view any preview files on the site.

false — restricts NetPublish site users from 
accessing any preview files. If the NetPublish site is 
configured to include preview images, the site will 
instead display a message indicating the images 
cannot be rendered.

watermark — each preview JPG is watermarked 
based on the watermark settings before it is provided 
to the NetPublish site user.
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watermarkAlign

center — places the watermark in the absolute 
center of the image.

topleft — places the watermark in the top left 
corner of the image.

bottomleft —  places the watermark in the lower 
left corner of the image.

bottomright — the default setting, this places 
watermark in the lower right corner.

tile — tiles the watermark across the target image.

fit — stretches the watermark GIF to fit corner-to-
corner across the target image.

watermarkOpacity

The opacity value can be any value from 0-100, and 
has a default setting of 50. This determines how 
opaque or transparent the watermark appears on 
the target image — from 0% where only the target 
image is visible to 100% where only the watermark 
image is visible. 

watermarkFile

This setting is the absolute path to the watermark 
GIF on the NetPublish server. Only GIF images are 
currently supported as watermark source files. 

Important notes about watermarking
When implementing or changing any watermark 
changes, it is important to clear the NetPublish 
site cache directory. This prevents NetPublish from 
inadvertently using previously generated (and 
possibly non-watermarked) images on the site. 

To clear the NetPublish cache:

•	 Delete all files from the following directory. 

	 The default location on a Windows server is:

	 C:\Program Files\Extensis\Portfolio 
NetPublish Server\Web Root\cache\

	 The default location on a Macintosh server is:

	 /Applications/Portfolio NetPublish 
Server/Web Root/cache/
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